Recovery_date_year range 1979 to 2025 is larger than 12 years -- unable to run HA2 report.